# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(['\"`]).*?\1(*SKIP)(*F)|\\n"
test_str = "\\nnew\"test\\naaaa\"\\nta\\n`this is a \\nnewline that should be kept`\\ntest\\n'this \\n should also be kept'\\n"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.