import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(['\"`]).*?\\1(*SKIP)(*F)|\\\\n";
final String string = "\\nnew\"test\\naaaa\"\\nta\\n`this is a \\nnewline that should be kept`\\ntest\\n'this \\n should also be kept'\\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}