# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<p[^<]*to school[^<]*<\\/p>//gm;t' <<< "$string = '<p>i need to go to my room</p><p>i don't need to go to school</p><p>i need to study everywhere</p>';"