$re = '/<p[^<]*to school[^<]*<\/p>/m';
$str = '$string = \'<p>i need to go to my room</p><p>i don\'t need to go to school</p><p>i need to study everywhere</p>\';';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;