using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p[^<]*to school[^<]*<\/p>";
string substitution = @"";
string input = @"$string = '<p>i need to go to my room</p><p>i don't need to go to school</p><p>i need to study everywhere</p>';";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}