#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<p[^<]*to school[^<]*<\/p>"
Local $sString = "$string = '<p>i need to go to my room</p><p>i don't need to go to school</p><p>i need to study everywhere</p>';"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)