// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<p[^<]*to school[^<]*<\/p>").unwrap();
let string = "$string = '<p>i need to go to my room</p><p>i don't need to go to school</p><p>i need to study everywhere</p>';";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}