package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<p[^<]*to school[^<]*<\/p>`)
var str = `$string = '<p>i need to go to my room</p><p>i don't need to go to school</p><p>i need to study everywhere</p>';`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}