use strict;
my $str = '$string = \'<p>i need to go to my room</p><p>i don\'t need to go to school</p><p>i need to study everywhere</p>\';';
my $regex = qr/<p[^<]*to school[^<]*<\/p>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";