re = /<p[^<]*to school[^<]*<\/p>/m
str = '$string = \'<p>i need to go to my room</p><p>i don\'t need to go to school</p><p>i need to study everywhere</p>\';'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result