const regex = /<p[^<]*to school[^<]*<\/p>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p[^<]*to school[^<]*<\\\/p>', 'gm')
const str = `\$string = '<p>i need to go to my room</p><p>i don't need to go to school</p><p>i need to study everywhere</p>';`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);