# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ALPHA(.*'(BI_\d+)')/\2\1/g;t' <<< "ALPHA;111,'BI_209'
ALPHA;222,'BI_213'
ALPHA;AAA,'BI_209'
ALPHA;FFF,'BI_209'
ALPHA;123,'BI_220'"