import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ALPHA(.*'(BI_\\d+)')";
final String string = "ALPHA;111,'BI_209'\n"
+ "ALPHA;222,'BI_213'\n"
+ "ALPHA;AAA,'BI_209'\n"
+ "ALPHA;FFF,'BI_209'\n"
+ "ALPHA;123,'BI_220'";
final String subst = "\\2\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}