package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`ALPHA(.*'(BI_\d+)')`)
var str = `ALPHA;111,'BI_209'
ALPHA;222,'BI_213'
ALPHA;AAA,'BI_209'
ALPHA;FFF,'BI_209'
ALPHA;123,'BI_220'`
var substitution = "\2\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}