import Foundation
let pattern = #"ALPHA(.*'(BI_\d+)')"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ALPHA;111,'BI_209'
ALPHA;222,'BI_213'
ALPHA;AAA,'BI_209'
ALPHA;FFF,'BI_209'
ALPHA;123,'BI_220'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)