re = /ALPHA(.*'(BI_\d+)')/
str = 'ALPHA;111,\'BI_209\'
ALPHA;222,\'BI_213\'
ALPHA;AAA,\'BI_209\'
ALPHA;FFF,\'BI_209\'
ALPHA;123,\'BI_220\''
subst = '\\2\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result