#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "ALPHA(.*'(BI_\d+)')"
Local $sString = "ALPHA;111,'BI_209'" & @CRLF & _
"ALPHA;222,'BI_213'" & @CRLF & _
"ALPHA;AAA,'BI_209'" & @CRLF & _
"ALPHA;FFF,'BI_209'" & @CRLF & _
"ALPHA;123,'BI_220'"
Local $sSubst = "\2\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)