using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ALPHA(.*'(BI_\d+)')";
string substitution = @"\2\1";
string input = @"ALPHA;111,'BI_209'
ALPHA;222,'BI_213'
ALPHA;AAA,'BI_209'
ALPHA;FFF,'BI_209'
ALPHA;123,'BI_220'";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}