use strict;
my $str = 'ALPHA;111,\'BI_209\'
ALPHA;222,\'BI_213\'
ALPHA;AAA,\'BI_209\'
ALPHA;FFF,\'BI_209\'
ALPHA;123,\'BI_220\'';
my $regex = qr/ALPHA(.*'(BI_\d+)')/p;
my $subst = '\\2\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";