# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\^ ( \( ( (?: [^()]* | (?-2) )* ) \) ) (?!.*\^\()/^{$2}/gx;t' <<< "this should be transformed a^(x²) and this b^(-(x²))"