use strict;
my $str = 'this should be transformed a^(x²) and this b^(-(x²))';
my $regex = qr/\^ ( \( ( (?: [^()]* | (?-2) )* ) \) ) (?!.*\^\()/xp;
my $subst = '^{$2}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";