import re
regex = re.compile(r"""
\^ ( \( ( (?: [^()]* | (?-2) )* ) \) ) (?!.*\^\()
""", flags=re.VERBOSE)
test_str = "this should be transformed a^(x²) and this b^(-(x²))"
subst = "^{$2}"
result = regex.sub(subst, test_str)
if result:
print(result)