import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\^ ( \\( ( (?: [^()]* | (?-2) )* ) \\) ) (?!.*\\^\\()";
final String string = "this should be transformed a^(x²) and this b^(-(x²))";
final String subst = "^{$2}";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}