$re = '/\^ ( \( ( (?: [^()]* | (?-2) )* ) \) ) (?!.*\^\()/x';
$str = 'this should be transformed a^(x²) and this b^(-(x²))';
$subst = "^{$2}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;