# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(a\s)(?:target=".*?"\s)?/$1target="_blank" /mg;t' <<< "<a target=\"_blank\" href=\"https://vk.com/\"></a>
<a href=\"/list\"></a>
<a href=\"https://vk.com/\"></a>
<a target=\"_self\" href=\"https://vk.com/\"></a>"