# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(a\s)(?:target=\".*?\"\s)?"
test_str = ("<a target=\"_blank\" href=\"https://vk.com/\"></a>\n"
"<a href=\"/list\"></a>\n"
"<a href=\"https://vk.com/\"></a>\n"
"<a target=\"_self\" href=\"https://vk.com/\"></a>")
subst = "$1target=\"_blank\" "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.