// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(a\s)(?:target=".*?"\s)?"#).unwrap();
let string = "<a target=\"_blank\" href=\"https://vk.com/\"></a>
<a href=\"/list\"></a>
<a href=\"https://vk.com/\"></a>
<a target=\"_self\" href=\"https://vk.com/\"></a>";
let substitution = "$1target=\"_blank\" ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}