#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(a\s)(?:target=".*?"\s)?"
Local $sString = "<a target="_blank" href="https://vk.com/"></a>" & @CRLF & _
"<a href="/list"></a>" & @CRLF & _
"<a href="https://vk.com/"></a>" & @CRLF & _
"<a target="_self" href="https://vk.com/"></a>"
Local $sSubst = "$1target="_blank" "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)