use strict;
my $str = '<a target="_blank" href="https://vk.com/"></a>
<a href="/list"></a>
<a href="https://vk.com/"></a>
<a target="_self" href="https://vk.com/"></a>';
my $regex = qr~(a\s)(?:target=".*?"\s)?~mp;
my $subst = '$1target="_blank" ';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";