import Foundation
let pattern = #"(a\s)(?:target=".*?"\s)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<a target="_blank" href="https://vk.com/"></a>
<a href="/list"></a>
<a href="https://vk.com/"></a>
<a target="_self" href="https://vk.com/"></a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1target="_blank" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)