package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(a\s)(?:target=".*?"\s)?`)
var str = `<a target="_blank" href="https://vk.com/"></a>
<a href="/list"></a>
<a href="https://vk.com/"></a>
<a target="_self" href="https://vk.com/"></a>`
var substitution = "$1target="_blank" "
fmt.Println(re.ReplaceAllString(str, substitution))
}