$re = '~(a\s)(?:target=".*?"\s)?~m';
$str = '<a target="_blank" href="https://vk.com/"></a>
<a href="/list"></a>
<a href="https://vk.com/"></a>
<a target="_self" href="https://vk.com/"></a>';
$subst = "$1target=\"_blank\" ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;