using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(a\s)(?:target="".*?""\s)?";
string substitution = @"$1target=""_blank"" ";
string input = @"<a target=""_blank"" href=""https://vk.com/""></a>
<a href=""/list""></a>
<a href=""https://vk.com/""></a>
<a target=""_self"" href=""https://vk.com/""></a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}