#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*)\s(?:s?|se)(\d+)\s?(?:e|x|ep)\s?(\d+)"
Local $sString = "Da Vinci's Demons se02ep04 whatsoever" & @CRLF & _
"Da Vinci's Demons se02 ep04" & @CRLF & _
"Da Vinci's Demons s02e123" & @CRLF & _
"Da Vinci's Demons s02 e04" & @CRLF & _
"Da Vinci's Demons 02x04" & @CRLF & _
"Da Vinci's Demons 02 x04" & @CRLF & _
"Da Vinci's Demons 02 x 04" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")