import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)\\s(?:s?|se)(\\d+)\\s?(?:e|x|ep)\\s?(\\d+)";
final String string = "Da Vinci's Demons se02ep04 whatsoever\n"
+ "Da Vinci's Demons se02 ep04\n"
+ "Da Vinci's Demons s02e123\n"
+ "Da Vinci's Demons s02 e04\n"
+ "Da Vinci's Demons 02x04\n"
+ "Da Vinci's Demons 02 x04\n"
+ "Da Vinci's Demons 02 x 04\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}