import re
regex = re.compile(r"(.*)\s(?:s?|se)(\d+)\s?(?:e|x|ep)\s?(\d+)", flags=re.MULTILINE)
test_str = ("Da Vinci's Demons se02ep04 whatsoever\n"
"Da Vinci's Demons se02 ep04\n"
"Da Vinci's Demons s02e123\n"
"Da Vinci's Demons s02 e04\n"
"Da Vinci's Demons 02x04\n"
"Da Vinci's Demons 02 x04\n"
"Da Vinci's Demons 02 x 04\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")