import Foundation
let pattern = #"(.*)\s(?:s?|se)(\d+)\s?(?:e|x|ep)\s?(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Da Vinci's Demons se02ep04 whatsoever
Da Vinci's Demons se02 ep04
Da Vinci's Demons s02e123
Da Vinci's Demons s02 e04
Da Vinci's Demons 02x04
Da Vinci's Demons 02 x04
Da Vinci's Demons 02 x 04
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)