package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)\s(?:s?|se)(\d+)\s?(?:e|x|ep)\s?(\d+)`)
var str = `Da Vinci's Demons se02ep04 whatsoever
Da Vinci's Demons se02 ep04
Da Vinci's Demons s02e123
Da Vinci's Demons s02 e04
Da Vinci's Demons 02x04
Da Vinci's Demons 02 x04
Da Vinci's Demons 02 x 04
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}