use strict;
my $str = 'Da Vinci\'s Demons se02ep04 whatsoever
Da Vinci\'s Demons se02 ep04
Da Vinci\'s Demons s02e123
Da Vinci\'s Demons s02 e04
Da Vinci\'s Demons 02x04
Da Vinci\'s Demons 02 x04
Da Vinci\'s Demons 02 x 04
';
my $regex = qr/(.*)\s(?:s?|se)(\d+)\s?(?:e|x|ep)\s?(\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}