// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)\s(?:s?|se)(\d+)\s?(?:e|x|ep)\s?(\d+)").unwrap();
let string = "Da Vinci's Demons se02ep04 whatsoever
Da Vinci's Demons se02 ep04
Da Vinci's Demons s02e123
Da Vinci's Demons s02 e04
Da Vinci's Demons 02x04
Da Vinci's Demons 02 x04
Da Vinci's Demons 02 x 04
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}