re = /(.*)\s(?:s?|se)(\d+)\s?(?:e|x|ep)\s?(\d+)/m
str = 'Da Vinci\'s Demons se02ep04 whatsoever
Da Vinci\'s Demons se02 ep04
Da Vinci\'s Demons s02e123
Da Vinci\'s Demons s02 e04
Da Vinci\'s Demons 02x04
Da Vinci\'s Demons 02 x04
Da Vinci\'s Demons 02 x 04
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end