const regex = /(.*)\s(?:s?|se)(\d+)\s?(?:e|x|ep)\s?(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)\\s(?:s?|se)(\\d+)\\s?(?:e|x|ep)\\s?(\\d+)', 'gm')
const str = `Da Vinci's Demons se02ep04 whatsoever
Da Vinci's Demons se02 ep04
Da Vinci's Demons s02e123
Da Vinci's Demons s02 e04
Da Vinci's Demons 02x04
Da Vinci's Demons 02 x04
Da Vinci's Demons 02 x 04
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}