# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^{,(\[\t=:;])\n/$1;\n/gm;t' <<< "var variable = something()
loop{
morphsvg
var
}"