re = /([^{,(\[\t=:;])\n/m
str = 'var variable = something()
loop{
morphsvg
var
}'
subst = '$1;\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result