$re = '/([^{,(\[\t=:;])\n/m';
$str = 'var variable = something()
loop{
morphsvg
var
}';
$subst = "$1;\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;