// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^{,(\[\t=:;])\n").unwrap();
let string = "var variable = something()
loop{
morphsvg
var
}";
let substitution = "$1;\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}