use strict;
my $str = 'var variable = something()
loop{
morphsvg
var
}';
my $regex = qr/([^{,(\[\t=:;])\n/mp;
my $subst = '$1;\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";