const regex = /([^{,(\[\t=:;])\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^{,(\\[\\t=:;])\\n', 'gm')
const str = `var variable = something()
loop{
morphsvg
var
}`;
const subst = `$1;\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);