using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^{,(\[\t=:;])\n";
string substitution = @"$1;\n";
string input = @"var variable = something()
loop{
morphsvg
var
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}