#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\W?1.*(\d{3}).*(\d{3}).*(\d{4})$"
Local $sString = "19999999999" & @CRLF & _
"+19999999999" & @CRLF & _
"1-999-999-9999" & @CRLF & _
"1-(999) 999-9999" & @CRLF & _
"238934265981239"
Local $sSubst = "1($1) $2-$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)